Britcoin Guides Easy guides on how to use Britcoin

Compiling Britcoin from source

How to compile Britcoind on Ubuntu.


Best-known instructions for compiling daemon (command-line version of Britcoin) on an Ubuntu system.

sudo apt-get -y update
sudo apt-get install -y libevent-dev git nano
sudo apt-get install -y gcc
sudo apt-get install -y openssl
sudo apt-get install -y libssl-dev g++
sudo apt-get install -y libboost-all-dev

sudo apt-get install -y software-properties-common
sudo add-apt-repository -y ppa:bitcoin/bitcoin 
sudo apt-get update -y
sudo apt-get install -y libdb4.8-dev libdb4.8++-dev

git clone https://github.com/britcoin3/britcoin3.3.git
cd britcoin3.3/src
make -f makefile.unix USE_UPNP=-

./britcoind -daemon

nano ~/.britcoin/britcoin.conf
(Paste in the stuff you were just given when you tried to run britcoind.  Ctrl+O to save, Ctrl+X to exit)

./britcoind -daemon


==============================
For the GUI (qt) version:

sudo apt-get -y update
sudo apt-get install -y libevent-dev git nano
sudo apt-get install -y gcc
sudo apt-get install -y openssl
sudo apt-get install -y libssl-dev g++
sudo apt-get install -y libboost-all-dev

sudo apt-get install -y software-properties-common
sudo add-apt-repository -y ppa:bitcoin/bitcoin 
sudo apt-get update -y
sudo apt-get install -y libdb4.8-dev libdb4.8++-dev

git clone https://github.com/britcoin3/britcoin3.3.git
cd britcoin3.3/src
make -f makefile.unix USE_UPNP=-

sudo apt-get install -y libqt5gui5 libqt5core5a libqt5webkit5-dev libqt5dbus5 qttools5-dev qttools5-dev-tools libqrencode-dev

cd ..
qmake && make

If you start seeing errors relating to qt4, use the qtchooser program to select QT 5, or explicitly use the QT version you want to use (e.g. ~/Qt5.5.0/5.5/gcc_64/bin/qmake && make )

QT 5.5 is recommended.